const regex = /\bx((Not Met|Minimal|Met|Exceed|Outstanding)\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bx((Not Met|Minimal|Met|Exceed|Outstanding)\\b)', 'gm')
const str = `"xNot Met /Minimal /Met /Exceed /Outstanding "
"/Not Met xMinimal /Met xExceed /Outstanding "
"/Not Met /Minimal /Met /Exceed xOutstanding "
"/Not Met /Minimal xMet /Exceed /Outstanding "
xMetx
jxNot Met`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}