#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?<!\S)#([0-9\p{L}]+)"
Local $sString = "Testing#one #two #three.test but also with chineese #печаль #грусть #fıstıklıbaklava #чайная #джаз"
Local $sSubst = "<a href="/hashtag/$1">#$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)