use strict;
my $str = 'Testing#one #two #three.test but also with chineese #печаль #грусть #fıstıklıbaklava #чайная #джаз';
my $regex = qr/(?<!\S)#([0-9\p{L}]+)/ip;
my $subst = '<a href="/hashtag/$1">#$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";