import Foundation
let pattern = ##"(?<!\S)#([0-9\p{L}]+)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"Testing#one #two #three.test but also with chineese #печаль #грусть #fıstıklıbaklava #чайная #джаз"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"<a href="/hashtag/$1">#$1</a>"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)