package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(20|23|24|27|30|33|34)\d{8}\d{1}$`)
var str = `20389812277`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}