#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=^|[^a-zA-Z0-9.+-])(?<version>(?<prefix>v?)(?<semver>(?<major>0|[1-9]\d*)\.(?<minor>0|[1-9]\d*)\.(?<patch>0|[1-9]\d*)(?:-(?<prerelease>(?:\d*[a-zA-Z-][0-9a-zA-Z-]*|[1-9]\d*|0)(?:\.(?:\d*[a-zA-Z-][0-9a-zA-Z-]*|[1-9]\d*|0))*))?(?:\+(?<build>[0-9a-zA-Z-]+(?:\.[0-9a-zA-Z-]+)*))?))(?=[^a-zA-Z0-9.+-]|$)"
Local $sString = "Valid Semantic Versions" & @CRLF & _
"" & @CRLF & _
"0.0.4" & @CRLF & _
"1.2.3" & @CRLF & _
"10.20.30" & @CRLF & _
"1.1.2-prerelease+meta" & @CRLF & _
"1.1.2+meta" & @CRLF & _
"1.1.2+meta-valid" & @CRLF & _
"1.0.0-alpha" & @CRLF & _
"1.0.0-beta" & @CRLF & _
"1.0.0-alpha.beta" & @CRLF & _
"1.0.0-alpha.beta.1" & @CRLF & _
"1.0.0-alpha.1" & @CRLF & _
"1.0.0-alpha0.valid" & @CRLF & _
"1.0.0-alpha.0valid" & @CRLF & _
"1.0.0-alpha-a.b-c-somethinglong+build.1-aef.1-its-okay" & @CRLF & _
"1.0.0-rc.1+build.1" & @CRLF & _
"2.0.0-rc.1+build.123" & @CRLF & _
"1.2.3-beta" & @CRLF & _
"10.2.3-DEV-SNAPSHOT" & @CRLF & _
"1.2.3-SNAPSHOT-123" & @CRLF & _
"1.0.0" & @CRLF & _
"2.0.0" & @CRLF & _
"1.1.7" & @CRLF & _
"2.0.0+build.1848" & @CRLF & _
"2.0.1-alpha.1227" & @CRLF & _
"1.0.0-alpha+beta" & @CRLF & _
"1.2.3----RC-SNAPSHOT.12.9.1--.12+788" & @CRLF & _
"1.2.3----R-S.12.9.1--.12+meta" & @CRLF & _
"1.2.3----RC-SNAPSHOT.12.9.1--.12" & @CRLF & _
"1.0.0+0.build.1-rc.10000aaa-kk-0.1" & @CRLF & _
"99999999999999999999999.999999999999999999.99999999999999999" & @CRLF & _
"1.0.0-0A.is.legal" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Invalid Semantic Versions" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"1.2" & @CRLF & _
"1.2.3-0123" & @CRLF & _
"1.2.3-0123.0123" & @CRLF & _
"1.1.2+.123" & @CRLF & _
"+invalid" & @CRLF & _
"-invalid" & @CRLF & _
"-invalid+invalid" & @CRLF & _
"-invalid.01" & @CRLF & _
"alpha" & @CRLF & _
"alpha.beta" & @CRLF & _
"alpha.beta.1" & @CRLF & _
"alpha.1" & @CRLF & _
"alpha+beta" & @CRLF & _
"alpha_beta" & @CRLF & _
"alpha." & @CRLF & _
"alpha.." & @CRLF & _
"beta" & @CRLF & _
"-alpha." & @CRLF & _
"1.0.0-alpha.." & @CRLF & _
"1.0.0-alpha..1" & @CRLF & _
"1.0.0-alpha...1" & @CRLF & _
"1.0.0-alpha....1" & @CRLF & _
"1.0.0-alpha.....1" & @CRLF & _
"1.0.0-alpha......1" & @CRLF & _
"1.0.0-alpha.......1" & @CRLF & _
"01.1.1" & @CRLF & _
"1.01.1" & @CRLF & _
"1.1.01" & @CRLF & _
"1.2" & @CRLF & _
"1.2.3.DEV" & @CRLF & _
"1.2-SNAPSHOT" & @CRLF & _
"1.2.31.2.3----RC-SNAPSHOT.12.09.1--..12+788" & @CRLF & _
"1.2-RC-SNAPSHOT" & @CRLF & _
"-1.0.3-gamma+b7718" & @CRLF & _
"+justmeta" & @CRLF & _
"9.8.7+meta+meta" & @CRLF & _
"9.8.7-whatever+meta+meta" & @CRLF & _
"99999999999999999999999.999999999999999999.99999999999999999----RC-SNAPSHOT.12.09.1--------------------------------..12"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)