// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^[^:]*((array|unassigned)*)[^:]*\n$").unwrap();
let string = "\"\"\"
Smart Array P822 in Slot 2
array A
array B
array C
SmartCache array D
Drive Authentication Status: Not Authenticated. Smart Array will not control drive LEDs.
array E
unassigned
\"\"\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}