re = /(?<=\s|^)[^.\s]+\.[^.\s]+(?=@)/m
str = 'blah blah blah test.this@gmail.com blah blah
blah blah blah test.this @gmail.com blah blah
blah blah blah test.this.this@gmail.com blah blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end