using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bfactuur(?:nummer|\n)?.*?(?<=\s)(\d+(?:\s*-\s*\d+)?)(?=\s|$)";
string input = @"Factuur: 2018-4005
Factuur
Nr. 90424571
Factuurnummer: 2019-010
dff factuur : 281319261
factuurnummer: 63
Factuurnummer: 281329164565
Factuur assdg 236373
Factuurnummer 281319265
Factuurnummer 0723 - 1345
Factuur nr. 180262
Factuurnummer : 6322232
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}