#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\"((http|https)\:\/\/([^\"]+)\.key)\""
Local $sString = "<a href="http://site.com/palavra.key"></a>" & @CRLF & _
"<a href="https://site.com/palavra.key"></a>" & @CRLF & _
"<a href="http://subdominio.site.com/palavra.key"></a>" & @CRLF & _
"<a href="https://subdominio.site.com/palavra.chave"></a>" & @CRLF & _
"<a href="http://subdominio.site.com/uma_coisa_qualquer.keykey"></a>" & @CRLF & _
"<a href="https://subdominio.site.com/outra_coisa_qualquer.key"></a>" & @CRLF & _
"<a href="https://subdominio.site.com/outra_coisa_qualquer.keys"></a>" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)