// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\"((http|https)\:\/\/([^\"]+)\.key)\""#).unwrap();
let string = "<a href=\"http://site.com/palavra.key\"></a>
<a href=\"https://site.com/palavra.key\"></a>
<a href=\"http://subdominio.site.com/palavra.key\"></a>
<a href=\"https://subdominio.site.com/palavra.chave\"></a>
<a href=\"http://subdominio.site.com/uma_coisa_qualquer.keykey\"></a>
<a href=\"https://subdominio.site.com/outra_coisa_qualquer.key\"></a>
<a href=\"https://subdominio.site.com/outra_coisa_qualquer.keys\"></a>
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}