using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|\(TRACK\s+""([^""]*)""\s+([PF]))\s+(\([SP](?:[^()]*+|(?-1))*\))\)?";
string input = @"Some crap string here...(TRACK ""title1"" F (S #h88 (P #m6) (P #m31)) (S #k3 (P #m58) (P #m58)))(TRACK ""title2"" P (S #a54 (P #r8)) (S #v59 (P #a25) (P #y82)))...Some other crap string here";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}