import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "var days = (\\[.*\\])";
final String string = "<script class=\"tester\">\n"
+ " /* описание */\n"
+ " var days = [\n"
+ " {\"period\": \"2023-04-11\", \"Buy\": 13, \"Purchase\": 34}, {\"period\": \"2023-04-10\", \"Buy\": 815, \"Purchase\": 107}, {\"period\": \"2023-04-09\", \"Buy\": 321, \"Purchase\": 40}, {\"period\": \"2023-04-08\", \"Buy\": 11, \"Purchase\": 18}, {\"period\": \"2023-04-07\", \"Buy\": 46, \"Purchase\": 57}, {\"period\": \"2023-04-06\", \"Buy\": 59, \"Purchase\": 13}, {\"period\": \"2023-04-05\", \"Buy\": 47, \"Purchase\": 99}\n"
+ " ];\n"
+ " </script>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}