const regex = /catch *\((\w+)\) *{[^}]+(\1)(\.stack)[^}]+}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('catch *\\((\\w+)\\) *{[^}]+(\\1)(\\.stack)[^}]+}', 'gm')
const str = `try {
print(new Function (astatement)())
} catch (e) { print(e.stack) }
try {
print(new Function (bstatement)())
} catch (exception) { print(exception.stack) }
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}