$re = '/catch *\((\w+)\) *{[^}]+(\1)(\.stack)[^}]+}/m';
$str = 'try {
print(new Function (astatement)())
} catch (e) { print(e.stack) }
try {
print(new Function (bstatement)())
} catch (exception) { print(exception.stack) }
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);