import re
regex = re.compile(r"^[@#](?=.{7,13}$)(?=\w{7,13})(?=[^aeiou_]{7,13})(?=.*[A-Z])(?=.*\d)", flags=re.MULTILINE)
test_str = ("@abgWds1\n"
"[rth521q\n"
"#mKK51d7\n"
"@WW65\n"
"@Ssgw_32\n"
"#kTl45e7\n"
"#kTl45z7\n"
"#kTlfvcr\n"
"#fg48Ehs\n"
"@rt51gwq\n"
"#456wrWE\n"
"#456wrW\n"
"#456w!!E\n"
"@fz6P$ww\n"
"@qz6P$wwazvbbneeeeeeeeeeeeeeeeeeeeee\n"
"@qz6PSwwszvbbn\n"
"@qz6PSwwszvbbneee")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")