import Foundation
let pattern = ##"^[@#](?=.{7,13}$)(?=\w{7,13})(?=[^aeiou_]{7,13})(?=.*[A-Z])(?=.*\d)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
@abgWds1
[rth521q
#mKK51d7
@WW65
@Ssgw_32
#kTl45e7
#kTl45z7
#kTlfvcr
#fg48Ehs
@rt51gwq
#456wrWE
#456wrW
#456w!!E
@fz6P$ww
@qz6P$wwazvbbneeeeeeeeeeeeeeeeeeeeee
@qz6PSwwszvbbn
@qz6PSwwszvbbneee
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)