#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\bXander\b.*$"
Local $sString = "Set of Xanderous" & @CRLF & _
"Set of hiXander" & @CRLF & _
"Set of hiXanderous" & @CRLF & _
"Xander Tray of 6" & @CRLF & _
"Tray of 6 pieces Xander" & @CRLF & _
"Set of 6 Xander pieces" & @CRLF & _
"Another test string"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")