#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)№(?P<lot>\d+).*дубина магических канделябров.*-(?P<cost>.*)\("
Local $sString = "лот №102: ⚔ топор бесстрашных канделябров ( 2) - 21 (начальная ставка)" & @CRLF & _
"лот №103: ⚔ дубина магических канделябров ( 2) - 26 (начальная ставка)" & @CRLF & _
"лот №104: ⚔ булава непобедимых побед ( 3) - 111 (начальная ставка"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")