import Foundation
let pattern = #"№(?P<lot>\d+).*дубина магических канделябров.*-(?P<cost>.*)\("#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
лот №102: ⚔ топор бесстрашных канделябров ( 2) - 21 (начальная ставка)
лот №103: ⚔ дубина магических канделябров ( 2) - 26 (начальная ставка)
лот №104: ⚔ булава непобедимых побед ( 3) - 111 (начальная ставка
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)