using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div\s+?(.*?)\s+?(id|class)\s*?=\s*?""(.+?)""\s+(.*)\s*?>";
string input = @"<div style = ""border: 1px"" id = ""header"" >
<div align=""left"" id=""nav"" style=""color:blue"">
<div class=""header"" style=""color:blue"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}