package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<div\s+?(.*?)\s+?(id|class)\s*?=\s*?"(.+?)"\s+(.*)\s*?>`)
var str = `<div style = "border: 1px" id = "header" >
<div align="left" id="nav" style="color:blue">
<div class="header" style="color:blue">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}