Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(?<!\d) (?: [0-9]{4} (?: (?:0[1-9]|1[0-2]) (?:0[1-9]|1[0-9]|2[0-8]) |(?:0[13-9]|1[0-2]) (?:29|30) |(?:0[13578]|1[02]) (?:31) ) | (?: [0-9]{2} (?: 0[48] |[2468][048] |[13579][26] ) |(?: 0[48] |[2468][048] |[13579][26] )00 ) 02 (?:29) ) (?!\d)
"
gx
Input 1
1
New
aaa_20150229_bbb aaa_2012-02-29_bbb aaa_2000-02-29_bbb aaa_20000229_bbb 20000228 2000-2-28 19120229 19000229 1696-2-29 16960229 20190228 aaa_1904229_bbb aaa_18000229_bbb aaa_17000229_bbb aaa_16000229_bbb 2019-3-30 19960229 2019-02-28 20190228 20190229 aaa_20150130_bbb aaa_20150131_bbb aaa_2015-04-30_bbb aaa_20150430_bbb 20190228 20190229 20200229 20000229 2000-02-29 2000-02-28 201911