# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b([A-Z]\w*)\s+(?=[A-Z])/\1_/gm;t' <<< "Roger Federer is a tennis player. Rafael Nadal Parera is also a tennis player. Another legend player is Novak Djokovic."