re = /(?P<digit>\d{3})-(?P<char>\w{4})&(?P=char)-(?P=digit)/
str = '123-abcd 123-abcd&abcd-123'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result