using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a(bb)";
string input = @"aabbabbabbaaa
expectedoutput
Start :1, End : 4, Group abb
Start :4, End : 7, Group abb
Start :7, End : 10,Group abb";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}