$re = '/^(?!.*\-\-)(?!.*\-.+\-.*\-)(?!-)[a-z0-9-]{0,52}(?<!-)$/mi';
$str = 'MycatBilly-Bobhas9lives
nlyallows52total
-thisshouldnotmatch
norshouldthis-
thisis--anotherbaddie
nothing-wrong-here
but-this-is-anono
thisistoolongfartoolongtomeetthemaximumlengthrequirement
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);