re = /^(?:https?:\/\/www\.foo\.com(?:\/\S*)*|sc-domain:www\.foo\.com)$/m
str = 'For example, the below entries should pass
https://www.foo.com/
https://www.foo.com/bar/
sc-domain:www.foo.com
However the below entries should fail
htps://www.foo.com/
https:/www.foo.com/bar/
sc-domain:www.foo.com/
sc-domain:www.foo.com/bar
scdomain:www.foo.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end