import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?://(?:\\w+\\.)+\\w+(?:/\\S*)*|sc-domain:(?:\\w+\\.)+\\w+)$";
final String string = "For example, the below entries should pass\n\n"
+ "https://www.foo.com/\n"
+ "https://www.foo.com/bar/\n"
+ "sc-domain:www.foo.com\n"
+ "sc-domain:abc.com\n"
+ "sc-domain:www.abc.com\n"
+ "https://www.abc.com/\n"
+ "https://abc.com/\n\n"
+ "However the below entries should fail\n\n"
+ "htps://www.foo.com/\n"
+ "https:/www.foo.com/bar/\n"
+ "sc-domain:www.foo.com/\n"
+ "sc-domain:www.foo.com/bar\n"
+ "scdomain:www.foo.com\n"
+ "sc-domain:abc.com/\n"
+ "sc-domain:abc.com/abc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}