# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d{4}(?:[,:]\d{4})*$"
test_str = ("1000\n"
"1200\n"
"1000:1200\n"
"1000,1200\n"
"1010:1015,1019,1025:1027\n"
"1000,1200,1100\n"
"1000:1001:1002\n"
"1000,1200,1100,\n"
"1201\n"
"999\n"
",1111\n"
":1111\n"
":1111,\n"
",1111:")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.