Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?:(?:\d{4}) (?:\d{3}) (?:\d{3})|(?:\d{2}) (?:\d{2}) (?:\d{2})|(?:\d{2}) (?:\d{4}) (?:\d{4})|(?:\d{4}) (?:\d{4}))$
/
g
Input 1
1
New
02 1234 5678 0412 345 678 1800 123 456 1300 123 456 13 12 34 1900 123 456 1902 123 456 1234 5678 02 25 45