import Foundation
let pattern = #"\b(\w+)\s\1\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Lorem ipsum ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Mauris ultrices eros in cursus turpis massa tincidunt. Ipsum a arcu cursus vitae congue. Lobortis mattis aliquam faucibus purus in massa. Pellentesque id nibh tortor id aliquet lectus proin nibh. Ultrices tincidunt arcu arcu non sodales neque sodales ut etiam. Enim praesent elementum facilisis leo vel fringilla. Sapien eget mi proin sed. Gravida arcu ac tortor dignissim convallis aenean et tortor at. Tortor consequat id porta nibh nibh venenatis. Tincidunt augue interdum velit euismod in pellentesque massa placerat. Pretium aenean pharetra magna ac placerat vestibulum. Fermentum posuere urna urna nec tincidunt praesent semper feugiat nibh. Sagittis aliquam malesuada bibendum arcu vitae elementum curabitur. Bibendum ut tristique et egestas quis ipsum suspendisse ultrices. Consectetur purus ut faucibus pulvinar elementum integer enim. Elementum nisi quis eleifend quam adipiscing vitae proin sagittis."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)