const regex = /tab/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('tab', 'gm')
const str = `tabtab`;
const subst = `\t`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);