using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SUPERTYPE OF\s\(\s*(\w+)\s*\)";
string input = @" ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF (
solid_with_stepped_round_hole)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF (
solid_with_stepped_round_hole)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF (solid_with_stepped_round_hole)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF ( solid_with_stepped_round_hole )
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
SUPERTYPE OF ( solid_with_stepped_round_hole
)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}