$re = '/SUPERTYPE OF\s\(\s*(\w+)\s*\)/m';
$str = ' ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF (
solid_with_stepped_round_hole)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF (
solid_with_stepped_round_hole)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF (solid_with_stepped_round_hole)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF ( solid_with_stepped_round_hole )
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
SUPERTYPE OF ( solid_with_stepped_round_hole
)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);