#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<unit_type>SFA)(?P<unit_size>80|63|50|40|32|25)(?P<mounting_type>G|F)(?P<tank_port>T|)(?P<decompression_feature>0|1)(?P<sep_1>-)(?P<unit_series>1X)(?P<sep_2>/)(?P<seal_material>M)(?P<sep_3>/)(?P<pipe_port>01)(?P<additional_details>(.|[0-9])*)$" & @CRLF & _
""
Local $sString = "SFA80F1-1X/M/01" & @CRLF & _
"SFA80F0-1X/M/01" & @CRLF & _
"SFA32G0-1X/M/01" & @CRLF & _
"SFA32GT0-1X/M/01" & @CRLF & _
"SFA32G1-1X/M/01" & @CRLF & _
"SFA40FT0-1X/M/01" & @CRLF & _
"SFA40F0-1X/M/01" & @CRLF & _
"SFA40F1-1X/M/01" & @CRLF & _
"SFA50F1-1X/M/01" & @CRLF & _
"SFA50F0-1X/M/01" & @CRLF & _
"SFA50FT0-1X/M/01" & @CRLF & _
"SFA63F0-1X/M/01" & @CRLF & _
"SFA63F1-1X/M/01" & @CRLF & _
"SFA63FT0-1X/M/01" & @CRLF & _
"SFA25G0-1X/M/01" & @CRLF & _
"SFA80FT1-1X/M/01" & @CRLF & _
"SFA80FT0-1X/M/01" & @CRLF & _
"SFA32GT1-1X/M/01" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")