using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<unit_type>SFA)(?P<unit_size>80|63|50|40|32|25)(?P<mounting_type>G|F)(?P<tank_port>T|)(?P<decompression_feature>0|1)(?P<sep_1>-)(?P<unit_series>1X)(?P<sep_2>/)(?P<seal_material>M)(?P<sep_3>/)(?P<pipe_port>01)(?P<additional_details>(.|[0-9])*)$
";
string input = @"SFA80F1-1X/M/01
SFA80F0-1X/M/01
SFA32G0-1X/M/01
SFA32GT0-1X/M/01
SFA32G1-1X/M/01
SFA40FT0-1X/M/01
SFA40F0-1X/M/01
SFA40F1-1X/M/01
SFA50F1-1X/M/01
SFA50F0-1X/M/01
SFA50FT0-1X/M/01
SFA63F0-1X/M/01
SFA63F1-1X/M/01
SFA63FT0-1X/M/01
SFA25G0-1X/M/01
SFA80FT1-1X/M/01
SFA80FT0-1X/M/01
SFA32GT1-1X/M/01
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}