const regex = /^0*(0\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0*(0\\d+)', 'gm')
const str = `00099999325
1254
1230004
0001230004`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);