use strict;
my $str = '00099999325
1254
1230004
0001230004';
my $regex = qr/^0*(0\d+)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";