$re = '/^0*(0\d+)/m';
$str = '00099999325
1254
1230004
0001230004';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;