import re
regex = re.compile(r"^0*(0\d+)", flags=re.MULTILINE)
test_str = ("00099999325\n"
"1254\n"
"1230004\n"
"0001230004")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)