re = /^0*(0\d+)/m
str = '00099999325
1254
1230004
0001230004'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result