#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m),.*\s([\d-]+)(?:$|\s)"
Local $sString = "2520222 Rubble,Barney 1134525" & @CRLF & _
"" & @CRLF & _
"1524356 Mudd,Harry S 14-40525 111.11" & @CRLF & _
"" & @CRLF & _
"2324316 Mudd,Mary R 12-40000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")