const regex = /,.*\s([\d-]+)(?:$|\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',.*\\s([\\d-]+)(?:$|\\s)', 'gm')
const str = `2520222 Rubble,Barney 1134525
1524356 Mudd,Harry S 14-40525 111.11
2324316 Mudd,Mary R 12-40000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}