#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(?<![-#/])literal(?!</a>)\b"
Local $sString = "<p>Literal in computer science is a" & @CRLF & _
"<a href='http://www.google.com/something/literal#literal'>literal</a>" & @CRLF & _
"for representing a fixed value in source code. Almost all programming " & @CRLF & _
"<a href='http://www.google.com/something/else-literal#literal'>languages</a>" & @CRLF & _
"have notations for atomic values such as integers, floating-point " & @CRLF & _
"numbers, and strings, and usually for booleans and characters; some" & @CRLF & _
"also have notations for elements of enumerated types and compound" & @CRLF & _
"values such as arrays, records, and objects. An anonymous function" & @CRLF & _
"is a literal for the function type which is LITERAL</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")