use strict;
my $str = '<p>Literal in computer science is a
<a href=\'http://www.google.com/something/literal#literal\'>literal</a>
for representing a fixed value in source code. Almost all programming
<a href=\'http://www.google.com/something/else-literal#literal\'>languages</a>
have notations for atomic values such as integers, floating-point
numbers, and strings, and usually for booleans and characters; some
also have notations for elements of enumerated types and compound
values such as arrays, records, and objects. An anonymous function
is a literal for the function type which is LITERAL</p>';
my $regex = qr~\b(?<![-#/])literal(?!</a>)\b~ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}