import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{1,2}\\s+d\\s?e?\\s+\\&?\\&?[a-zà-ü]{4,9}\\s+[0-9]{4}\\,?\\s?([àa]s\\s+)?\\&?\\&?[0-9]{2}(:|h|h:)[0-9]{2})";
final String string = "1º LEILÃO - 25 de outubro 2018 às 14h30min - LANCE MÍNIMO R$ 260.000,00\n"
+ "2º LEILÃO - 06 de novembro 2018 às 14h30min\n"
+ "06 de novembro de 2018 às 14h30min";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}