const regex = new RegExp('([0-9]{1,2}\\s+d\\s?e?\\s+\\&?\\&?[a-zà-ü]{4,9}\\s+[0-9]{4}\\,?\\s?([àa]s\\s+)?\\&?\\&?[0-9]{2}(:|h|h:)[0-9]{2})', 'g')
const str = `1º LEILÃO - 25 de outubro 2018 às 14h30min - LANCE MÍNIMO R\$ 260.000,00
2º LEILÃO - 06 de novembro 2018 às 14h30min
06 de novembro de 2018 às 14h30min`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}