$re = '/([0-9]{1,2}\s+d\s?e?\s+\&?\&?[a-zà-ü]{4,9}\s+[0-9]{4}\,?\s?([àa]s\s+)?\&?\&?[0-9]{2}(:|h|h:)[0-9]{2})/';
$str = '1º LEILÃO - 25 de outubro 2018 às 14h30min - LANCE MÍNIMO R$ 260.000,00
2º LEILÃO - 06 de novembro 2018 às 14h30min
06 de novembro de 2018 às 14h30min';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);