re = /^((?:https?|ftp):\/\/?)?([^:\/\s.]+\.[^:\/\s]|localhost)(:\d+)?((?:\/\w+)*\/)?([\w\-.]+[^#?\s]+)?([^#]*)?(#[\w-]*)?$/m
str = 'https://localhost:8000/dir/1/2/search.html?k1=v1&k2=v2&k3#hash
google.ca'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end